Medium, CVSS 5.1MavenPublished
Liferay search widget vulnerable to Cross-site Scripting
CVE-2025-43804 · GHSA-ccrc-5vp5-vp5j
- Affected
- Maven com.liferay:com.liferay.portal.search < 8.0.93
- Fixed in
- 8.0.93· Vendor fix available
- Issue
- There is a Cross-site scripting (XSS) vulnerability in Liferay Portal's Search widget . Versions 7.4.3.93 through 7.4.3.111, and Liferay DXP 2023.Q4.0, 2023.Q3.1 through 2023.Q3.4 allow remote attackers to inject arbitrary web scripts or HTML via the comliferayportalsearchwebportletSearchPortletuserId parameter.
Recommended action: Upgrade to 8.0.93 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.