Liferay search widget vulnerable to Cross-site Scripting
CVE-2025-43804GHSA-ccrc-5vp5-vp5j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.liferay:com.liferay.portal.search 8.0.93), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.liferay:com.liferay.portal.search
- Affected
- < 8.0.93
- Fixed in
- 8.0.93
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-ccrc-5vp5-vp5j lists affected ranges: Maven com.liferay:com.liferay.portal.search >=0 <8.0.93
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-43804: 0.23% estimated exploitation activity in the next 30 days; percentile 14.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
There is a Cross-site scripting (XSS) vulnerability in Liferay Portal's Search widget . Versions 7.4.3.93 through 7.4.3.111, and Liferay DXP 2023.Q4.0, 2023.Q3.1 through 2023.Q3.4 allow remote attackers to inject arbitrary web scripts or HTML via the comliferayportalsearchwebportletSearchPortletuserId parameter.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-ccrc-5vp5-vp5j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-43804 Advisory: Liferay search widget vulnerable to Cross-site Scripting IDs: CVE-2025-43804, GHSA-ccrc-5vp5-vp5j Record: https://patchnext.com/advisories/cve-2025-43804 (revision 1, source checked 26 Oct 2026, 16:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.liferay:com.liferay.portal.search 8.0.93. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.liferay:com.liferay.portal.search: affected < 8.0.93; fixed in 8.0.93 ## Suggested inspection (read-only) - Maven com.liferay:com.liferay.portal.search: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.liferay:com.liferay.portal.search. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-ccrc-5vp5-vp5j (GitHub-reviewed advisory GHSA-ccrc-5vp5-vp5j lists affected ranges: Maven com.liferay:com.liferay.portal.search >=0 <8.0.93) Commands are suggestions: review each one before running it.
Loading voting…