Skip to content

← Public intelligence

Maven package

com.liferay:com.liferay.item.selector.web

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.8MavenPublished

    Liferay Portal vulnerable to cross-site scripting in the related asset selector

    CVE-2025-43811 · GHSA-2856-xf2f-6vrf

    Affected
    • Maven com.liferay:com.liferay.item.selector.web >= 7.0.35, < 7.0.52
    Fixed in
    7.0.52· Vendor fix available
    Issue
    Multiple stored cross-site scripting (XSS) vulnerability in the related asset selector in Liferay Portal 7.4.3.50 through 7.4.3.111, and Liferay DXP 2023.Q4.0 through 2023.Q4.4, 2023.Q3.1 through 2023.Q3.7, and 7.4 update 50 through update 92 allows remote authenticated attackers to inject arbitrary web script or HTML via a crafted payload injected into an asset author’s (1) First Name, (2) Middle Name, or (3) Last Name text field.

    Recommended action: Upgrade to 7.0.52 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →