Skip to content

← Actionable
Medium, CVSS 4.8

Liferay Portal vulnerable to cross-site scripting in the related asset selector

CVE-2025-43811GHSA-2856-xf2f-6vrf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.liferay:com.liferay.item.selector.web 7.0.52), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-43811: 0.22% estimated exploitation activity in the next 30 days; percentile 13.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Multiple stored cross-site scripting (XSS) vulnerability in the related asset selector in Liferay Portal 7.4.3.50 through 7.4.3.111, and Liferay DXP 2023.Q4.0 through 2023.Q4.4, 2023.Q3.1 through 2023.Q3.7, and 7.4 update 50 through update 92 allows remote authenticated attackers to inject arbitrary web script or HTML via a crafted payload injected into an asset author’s (1) First Name, (2) Middle Name, or (3) Last Name text field.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2856-xf2f-6vrf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-43811

Advisory: Liferay Portal vulnerable to cross-site scripting in the related asset selector
IDs: CVE-2025-43811, GHSA-2856-xf2f-6vrf
Record: https://patchnext.com/advisories/cve-2025-43811 (revision 1, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.liferay:com.liferay.item.selector.web 7.0.52. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.liferay:com.liferay.item.selector.web: affected >= 7.0.35, < 7.0.52; fixed in 7.0.52

## Suggested inspection (read-only)
- Maven com.liferay:com.liferay.item.selector.web: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.liferay:com.liferay.item.selector.web.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2856-xf2f-6vrf (GitHub-reviewed advisory GHSA-2856-xf2f-6vrf lists affected ranges: Maven com.liferay:com.liferay.item.selector.web >=7.0.35 <7.0.52)

Commands are suggestions: review each one before running it.

Loading voting…