High, CVSS 7.1MavenPublished
Karate has vulnerable dependency on json-smart package (CVE-2023-1370)
GHSA-5x5q-8cgm-2hjq
- Affected
- Maven com.intuit.karate:karate-core >= 1.3.1, <= 1.3.1
- Fixed in
- 1.4.0· Vendor fix available
- Issue
- The CVE How to fix it Very simple, just upgrade json-path package to 2.8.0 (from 2.7.0) inside karate-core pom.xml ;)
Recommended action: Upgrade to 1.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.