Karate has vulnerable dependency on json-smart package (CVE-2023-1370)
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.intuit.karate:karate-core 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.intuit.karate:karate-core
- Affected
- >= 1.3.1, <= 1.3.1
- Fixed in
- 1.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5x5q-8cgm-2hjq lists affected ranges: Maven com.intuit.karate:karate-core >=1.3.1 <=1.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary The CVE How to fix it Very simple, just upgrade json-path package to 2.8.0 (from 2.7.0) inside karate-core pom.xml ;)
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5x5q-8cgm-2hjq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-5x5q-8cgm-2hjq Advisory: Karate has vulnerable dependency on json-smart package (CVE-2023-1370) IDs: GHSA-5x5q-8cgm-2hjq Record: https://patchnext.com/advisories/ghsa-5x5q-8cgm-2hjq (revision 1, source checked 26 Oct 2026, 16:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.intuit.karate:karate-core 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.intuit.karate:karate-core: affected >= 1.3.1, <= 1.3.1; fixed in 1.4.0 ## Suggested inspection (read-only) - Maven com.intuit.karate:karate-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.intuit.karate:karate-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5x5q-8cgm-2hjq (GitHub-reviewed advisory GHSA-5x5q-8cgm-2hjq lists affected ranges: Maven com.intuit.karate:karate-core >=1.3.1 <=1.3.1) Commands are suggestions: review each one before running it.
Loading voting…