Skip to content

← Public intelligence

Maven package

com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1MavenPublished

    Cross-site Scripting in wicket-jquery-ui

    CVE-2018-1325 · GHSA-pjv3-rh6v-2pj8

    Affected
    • Maven com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent < 6.29.1; >= 7.0.0, < 7.10.2; >= 8.0.0-M1, < 8.0.0-M9.2
    Fixed in
    8.0.0-M9.26.29.17.10.2· Vendor fix available
    Issue
    In wicket-jquery-ui <= 6.29.0, <= 7.10.1, <= 8.0.0-M9.1, JS code created in WYSIWYG editor will be executed on display.

    Recommended action: Upgrade to 8.0.0-M9.2 (pre-release), 7.10.2 or 6.29.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.1MavenPublished

    Cross-site Scripting in wicket-jquery-ui

    CVE-2017-15719 · GHSA-pwpc-hqq2-hx2x

    Affected
    • Maven com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent < 6.28.1; >= 7.0.0, < 7.9.2; >= 8.0.0-M1, < 8.0.0-M8.1
    Fixed in
    6.28.17.9.28.0.0-M8.1· Vendor fix available
    Issue
    In Wicket jQuery UI 6.28.0 and earlier, 7.9.1 and earlier, and 8.0.0-M8 and earlier, a security issue has been discovered in the WYSIWYG editor that allows an attacker to submit arbitrary JS code to WYSIWYG editor.

    Recommended action: Upgrade to 8.0.0-M8.1 (pre-release), 7.9.2 or 6.28.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →