Skip to content

← Actionable
Medium, CVSS 6.1

Cross-site Scripting in wicket-jquery-ui

CVE-2018-1325GHSA-pjv3-rh6v-2pj8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent 8.0.0-M9.2, 7.10.2, 6.29.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-pjv3-rh6v-2pj8 lists affected ranges: Maven com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent >=0 =7.0.0 =8.0.0-M1 <8.0.0-M9.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2018-1325: 0.81% estimated exploitation activity in the next 30 days; percentile 56.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In wicket-jquery-ui <= 6.29.0, <= 7.10.1, <= 8.0.0-M9.1, JS code created in WYSIWYG editor will be executed on display.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pjv3-rh6v-2pj8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-1325

Advisory: Cross-site Scripting in wicket-jquery-ui
IDs: CVE-2018-1325, GHSA-pjv3-rh6v-2pj8
Record: https://patchnext.com/advisories/cve-2018-1325 (revision 1, source checked 26 Oct 2026, 16:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent 8.0.0-M9.2, 7.10.2, 6.29.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent: affected < 6.29.1; >= 7.0.0, < 7.10.2; >= 8.0.0-M1, < 8.0.0-M9.2; fixed in 8.0.0-M9.2, 6.29.1, 7.10.2

## Suggested inspection (read-only)
- Maven com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pjv3-rh6v-2pj8 (GitHub-reviewed advisory GHSA-pjv3-rh6v-2pj8 lists affected ranges: Maven com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parent >=0 =7.0.0 =8.0.0-M1 <8.0.0-M9.2)

Commands are suggestions: review each one before running it.

Loading voting…