Medium, CVSS 6.5MavenPublished
Exposure of system-scoped Kubernetes credentials in Jenkins Kubernetes Credentials Provider Plugin
CVE-2023-24425 · GHSA-2jpx-h8j2-g8m4
- Affected
- Maven com.cloudbees.jenkins.plugins:kubernetes-credentials-provider < 1.209.v862c6e5fb
- Fixed in
- 1.209.v862c6e5fb· Vendor fix available
- Issue
- Jenkins Kubernetes Credentials Provider Plugin 1.208.v128ee9800c04 and earlier does not set the appropriate context for Kubernetes credentials lookup, allowing attackers with Item/Configure permission to access and potentially capture Kubernetes credentials they are not entitled to.
Recommended action: Upgrade to 1.209.v862c6e5fb or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.