Exposure of system-scoped Kubernetes credentials in Jenkins Kubernetes Credentials Provider Plugin
CVE-2023-24425GHSA-2jpx-h8j2-g8m4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.cloudbees.jenkins.plugins:kubernetes-credentials-provider 1.209.v862c6e5fb), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.cloudbees.jenkins.plugins:kubernetes-credentials-provider
- Affected
- < 1.209.v862c6e5fb
- Fixed in
- 1.209.v862c6e5fb
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2jpx-h8j2-g8m4 lists affected ranges: Maven com.cloudbees.jenkins.plugins:kubernetes-credentials-provider >=0 <1.209.v862c6e5fb
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-24425: 0.82% estimated exploitation activity in the next 30 days; percentile 57.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins Kubernetes Credentials Provider Plugin 1.208.v128ee9800c04 and earlier does not set the appropriate context for Kubernetes credentials lookup, allowing attackers with Item/Configure permission to access and potentially capture Kubernetes credentials they are not entitled to.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2jpx-h8j2-g8m4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-24425 Advisory: Exposure of system-scoped Kubernetes credentials in Jenkins Kubernetes Credentials Provider Plugin IDs: CVE-2023-24425, GHSA-2jpx-h8j2-g8m4 Record: https://patchnext.com/advisories/cve-2023-24425 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.cloudbees.jenkins.plugins:kubernetes-credentials-provider 1.209.v862c6e5fb. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.cloudbees.jenkins.plugins:kubernetes-credentials-provider: affected < 1.209.v862c6e5fb; fixed in 1.209.v862c6e5fb ## Suggested inspection (read-only) - Maven com.cloudbees.jenkins.plugins:kubernetes-credentials-provider: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.cloudbees.jenkins.plugins:kubernetes-credentials-provider. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2jpx-h8j2-g8m4 (GitHub-reviewed advisory GHSA-2jpx-h8j2-g8m4 lists affected ranges: Maven com.cloudbees.jenkins.plugins:kubernetes-credentials-provider >=0 <1.209.v862c6e5fb) Commands are suggestions: review each one before running it.
Loading voting…