Skip to content

← Public intelligence

Maven package

com.amazonaws:codedeploy

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3MavenPublished

    Jenkins AWS CodeDeploy Plugin has Insufficiently Protected Credentials

    CVE-2018-1000402 · GHSA-644j-jcc4-crx7

    Affected
    • Maven com.amazonaws:codedeploy < 1.20
    Fixed in
    1.20· Vendor fix available
    Issue
    Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a File and Directory Information Exposure vulnerability in AWSCodeDeployPublisher.java that can result in Disclosure of environment variables. This vulnerability appears to have been fixed in 1.20 and later.

    Recommended action: Upgrade to 1.20 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.8MavenPublished

    AWS CodeDeploy Plugin stored AWS Secret Key in plain text

    CVE-2018-1000403 · GHSA-h66p-m766-33fv

    Affected
    • Maven com.amazonaws:codedeploy < 1.20
    Fixed in
    1.20· Vendor fix available
    Issue
    Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodeDeployPublisher.java that can result in Credentials Disclosure. This attack appears to be exploitable via local file access. AWS CodeDeploy Plugin 1.20 and newer stores the AWS Secret Key encrypted in the configuration files on disk and no longer transfers it to users viewing the configuration form in plain text. Existing jobs need to have their configuration saved for existing plain text secret keys to be overwritten.

    Recommended action: Upgrade to 1.20 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →