Jenkins AWS CodeDeploy Plugin has Insufficiently Protected Credentials
CVE-2018-1000402GHSA-644j-jcc4-crx7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.amazonaws:codedeploy 1.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.amazonaws:codedeploy
- Affected
- < 1.20
- Fixed in
- 1.20
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-644j-jcc4-crx7 lists affected ranges: Maven com.amazonaws:codedeploy >=0 <1.20
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2018-1000402: 0.97% estimated exploitation activity in the next 30 days; percentile 61.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a File and Directory Information Exposure vulnerability in AWSCodeDeployPublisher.java that can result in Disclosure of environment variables. This vulnerability appears to have been fixed in 1.20 and later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-644j-jcc4-crx7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-1000402 Advisory: Jenkins AWS CodeDeploy Plugin has Insufficiently Protected Credentials IDs: CVE-2018-1000402, GHSA-644j-jcc4-crx7 Record: https://patchnext.com/advisories/cve-2018-1000402 (revision 1, source checked 26 Oct 2026, 16:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.amazonaws:codedeploy 1.20. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.amazonaws:codedeploy: affected < 1.20; fixed in 1.20 ## Suggested inspection (read-only) - Maven com.amazonaws:codedeploy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.amazonaws:codedeploy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-644j-jcc4-crx7 (GitHub-reviewed advisory GHSA-644j-jcc4-crx7 lists affected ranges: Maven com.amazonaws:codedeploy >=0 <1.20) Commands are suggestions: review each one before running it.
Loading voting…