Skip to content

← Public intelligence

Go package

volcano.sh/volcano

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.8GoPublished

    Volcano's webhook server vulnerable to OOM due to unbounded HTTP request body size

    CVE-2026-44247 · GHSA-8wxp-xxp2-rcgx

    Affected
    • Go volcano.sh/volcano < 1.12.4; >= 1.13.0, < 1.13.3; >= 1.14.0, < 1.14.2
    Fixed in
    1.12.41.14.21.13.3· Vendor fix available
    Issue
    Impact The Volcano webhook server does not enforce a size limit on incoming HTTP request bodies. Any in-cluster pod that can reach the webhook endpoint may send an arbitrarily large request body, potentially causing the webhook server to be killed by OOM. All Volcano deployments with the webhook server exposed to in-cluster traffic are affected. Patches This issue will be fixed in the following versions: - v1.14.2 - v1.13.3 - v1.12.4 Users running versions below these should upgrade accordingly. Workarounds No known workarounds. Upgrade to the patched versions listed above.

    Recommended action: Upgrade to 1.14.2, 1.13.3 or 1.12.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.2GoPublished

    Volcano Scheduler Denial of Service via Unbounded Response from Elastic Service/extender Plugin

    CVE-2025-32777 · GHSA-hg79-fw4p-25p8

    Affected
    • Go volcano.sh/volcano < 1.9.1; >= 1.10.0-alpha.0, < 1.10.2; >= 1.11.0-network-topology-preview.0, < 1.11.0-network-topology-preview.3; >= 1.11.0, < 1.11.2; >= 1.12.0-alpha.0, < 1.12.0-alpha.2
    Fixed in
    1.12.0-alpha.21.11.21.11.0-network-topology-preview.31.9.11.10.2· Vendor fix available
    Issue
    Impact This issue allows an attacker who has compromised either the Elastic service or the extender plugin to cause denial of service of the scheduler. This is a privilege escalation, because Volcano users may run their Elastic service and extender plugins in separate pods or nodes from the scheduler. In the Kubernetes security model, node isolation is a security boundary, and as such an attacker is able to cross that boundary in Volcano's case if they have compromised either the vulnerable services or the pod/node in which they are deployed. The scheduler will become unavailable to other users and workloads in the cluster. The scheduler will either crash with an unrecoverable OOM panic or freeze while consuming excessive amounts of memory. Workarounds No

    Recommended action: Upgrade to 1.12.0-alpha.2 (pre-release), 1.11.2, 1.11.0-network-topology-preview.3 (pre-release) or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.3GoPublished

    Volcano has insecure permissions

    CVE-2024-36533 · GHSA-5g3x-8g2v-r8x8

    Affected
    • Go volcano.sh/volcano < 1.10.0-alpha.0
    Fixed in
    1.10.0-alpha.0· Vendor fix available
    Issue
    Insecure permissions in volcano v1.8.2 allows attackers to access sensitive data and escalate privileges by obtaining the service account's token.

    Recommended action: Upgrade to 1.10.0-alpha.0 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →