Volcano Scheduler Denial of Service via Unbounded Response from Elastic Service/extender Plugin
CVE-2025-32777GHSA-hg79-fw4p-25p8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (volcano.sh/volcano 1.12.0-alpha.2, 1.11.2, 1.11.0-network-topology-preview.3, 1.10.2, 1.9.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.9.1>= 1.10.0-alpha.0, < 1.10.2>= 1.11.0-network-topology-preview.0, < 1.11.0-network-topology-preview.3>= 1.11.0, < 1.11.2>= 1.12.0-alpha.0, < 1.12.0-alpha.2
- Fixed in
- 1.12.0-alpha.2, 1.11.2, 1.11.0-network-topology-preview.3, 1.9.1, 1.10.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hg79-fw4p-25p8 lists affected ranges: Go volcano.sh/volcano >=0 =1.10.0-alpha.0 =1.11.0-network-topology-preview.0 =1.11.0 =1.12.0-alpha.0 <1.12.0-alpha.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:H/VA:H/SC:N/SI:H/SA:H · score source
- EPSS
- CVE-2025-32777: 0.48% estimated exploitation activity in the next 30 days; percentile 41.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This issue allows an attacker who has compromised either the Elastic service or the extender plugin to cause denial of service of the scheduler. This is a privilege escalation, because Volcano users may run their Elastic service and extender plugins in separate pods or nodes from the scheduler. In the Kubernetes security model, node isolation is a security boundary, and as such an attacker is able to cross that boundary in Volcano's case if they have compromised either the vulnerable services or the pod/node in which they are deployed. The scheduler will become unavailable to other users and workloads in the cluster. The scheduler will either crash with an unrecoverable OOM panic or freeze while consuming excessive amounts of memory. Workarounds No
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hg79-fw4p-25p8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-32777 Advisory: Volcano Scheduler Denial of Service via Unbounded Response from Elastic Service/extender Plugin IDs: CVE-2025-32777, GHSA-hg79-fw4p-25p8 Record: https://patchnext.com/advisories/cve-2025-32777 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: volcano.sh/volcano 1.12.0-alpha.2, 1.11.2, 1.11.0-network-topology-preview.3, 1.10.2, 1.9.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go volcano.sh/volcano: affected < 1.9.1; >= 1.10.0-alpha.0, < 1.10.2; >= 1.11.0-network-topology-preview.0, < 1.11.0-network-topology-preview.3; >= 1.11.0, < 1.11.2; >= 1.12.0-alpha.0, < 1.12.0-alpha.2; fixed in 1.12.0-alpha.2, 1.11.2, 1.11.0-network-topology-preview.3, 1.9.1, 1.10.2 ## Suggested inspection (read-only) - Go volcano.sh/volcano: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on volcano.sh/volcano. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hg79-fw4p-25p8 (GitHub-reviewed advisory GHSA-hg79-fw4p-25p8 lists affected ranges: Go volcano.sh/volcano >=0 =1.10.0-alpha.0 =1.11.0-network-topology-preview.0 =1.11.0 =1.12.0-alpha.0 <1.12.0-alpha.2) Commands are suggestions: review each one before running it.
Loading voting…