High, CVSS 8.0GoPublished
kOps privilege escalation vulnerability
CVE-2023-1943 · GHSA-8gwj-m6vh-2g6j
- Affected
- Go k8s.io/kops < 1.25.4; >= 1.26.0, < 1.26.2
- Fixed in
- 1.25.41.26.2· Vendor fix available
- Issue
- Privilege Escalation in kOps using GCE/GCP Provider in Gossip Mode.
Recommended action: Upgrade to 1.26.2 or 1.25.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.