Skip to content

← Actionable
High, CVSS 8.0

kOps privilege escalation vulnerability

CVE-2023-1943GHSA-8gwj-m6vh-2g6j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/kops 1.26.2, 1.25.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go k8s.io/kops

    Affected
    < 1.25.4>= 1.26.0, < 1.26.2
    Fixed in
    1.25.4, 1.26.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2023-1943: 0.58% estimated exploitation activity in the next 30 days; percentile 48.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Privilege Escalation in kOps using GCE/GCP Provider in Gossip Mode.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8gwj-m6vh-2g6j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-1943

Advisory: kOps privilege escalation vulnerability
IDs: CVE-2023-1943, GHSA-8gwj-m6vh-2g6j
Record: https://patchnext.com/advisories/cve-2023-1943 (revision 1, source checked 26 Oct 2026, 14:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: k8s.io/kops 1.26.2, 1.25.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go k8s.io/kops: affected < 1.25.4; >= 1.26.0, < 1.26.2; fixed in 1.25.4, 1.26.2

## Suggested inspection (read-only)
- Go k8s.io/kops: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on k8s.io/kops.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8gwj-m6vh-2g6j (GitHub-reviewed advisory GHSA-8gwj-m6vh-2g6j lists affected ranges: Go k8s.io/kops >=0 =1.26.0 <1.26.2)

Commands are suggestions: review each one before running it.

Loading voting…