Medium, CVSS 5.3GoPublished
Kubernetes API Server DoS Via API Requests
CVE-2020-8552 · GHSA-82hx-w2r5-c2wq
- Affected
- Go k8s.io/apiserver < 0.15.10; >= 0.16.0, < 0.16.7; >= 0.17.0, < 0.17.3
- Fixed in
- 0.16.70.15.100.17.3· Vendor fix available
- Issue
- The Kubernetes API server component in Kubernetes versions prior to 1.15.9, 1.16.0-1.16.6, and 1.17.0-1.17.2 has been found to be vulnerable to a denial of service attack via successful API requests.
Recommended action: Upgrade to 0.17.3, 0.16.7 or 0.15.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.