Kubernetes API Server DoS Via API Requests
CVE-2020-8552GHSA-82hx-w2r5-c2wq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/apiserver 0.17.3, 0.16.7, 0.15.10), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.15.10>= 0.16.0, < 0.16.7>= 0.17.0, < 0.17.3
- Fixed in
- 0.16.7, 0.15.10, 0.17.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-82hx-w2r5-c2wq lists affected ranges: Go k8s.io/apiserver >=0 =0.16.0 =0.17.0 <0.17.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2020-8552: 2.96% estimated exploitation activity in the next 30 days; percentile 87.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Kubernetes API server component in Kubernetes versions prior to 1.15.9, 1.16.0-1.16.6, and 1.17.0-1.17.2 has been found to be vulnerable to a denial of service attack via successful API requests.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-82hx-w2r5-c2wq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-8552 Advisory: Kubernetes API Server DoS Via API Requests IDs: CVE-2020-8552, GHSA-82hx-w2r5-c2wq Record: https://patchnext.com/advisories/cve-2020-8552 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: k8s.io/apiserver 0.17.3, 0.16.7, 0.15.10. A vendor fix does not mean a deployment is fixed. ## Affected components - Go k8s.io/apiserver: affected < 0.15.10; >= 0.16.0, < 0.16.7; >= 0.17.0, < 0.17.3; fixed in 0.16.7, 0.15.10, 0.17.3 ## Suggested inspection (read-only) - Go k8s.io/apiserver: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on k8s.io/apiserver. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-82hx-w2r5-c2wq (GitHub-reviewed advisory GHSA-82hx-w2r5-c2wq lists affected ranges: Go k8s.io/apiserver >=0 =0.16.0 =0.17.0 <0.17.3) Commands are suggestions: review each one before running it.
Loading voting…