Skip to content

← Public intelligence

Go package

helm.sh/helm

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8GoPublished

    Helm Unsafe Link Following

    CVE-2019-18658 · GHSA-p5pc-m4q7-7qm9

    Affected
    • Go helm.sh/helm >= 2.0.0, < 2.15.2
    Fixed in
    2.15.2· Vendor fix available
    Issue
    In Helm 2.x before 2.15.2, commands that deal with loading a chart as a directory or packaging a chart provide an opportunity for a maliciously designed chart to include sensitive content such as /etc/passwd, or to execute a denial of service (DoS) via a special file such as /dev/urandom, via symlinks. No version of Tiller is known to be impacted. This is a client-only issue.

    Recommended action: Upgrade to 2.15.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8GoPublished

    Helm Improper Certificate Validation

    CVE-2019-1010275 · GHSA-x6r5-vxfg-gq3v

    Affected
    • Go helm.sh/helm < 2.7.2
    Fixed in
    2.7.2· Vendor fix available
    Issue
    helm Before 2.7.2 is affected by: CWE-295: Improper Certificate Validation. The impact is: Unauthorized clients could connect to the server because self-signed client certs were aloowed. The component is: helm (many files updated, see https://github.com/helm/helm/pull/3152/files/1096813bf9a425e2aa4ac755b6c991b626dfab50). The attack vector is: A malicious client could connect to the server over the network. The fixed version is: 2.7.2.

    Recommended action: Upgrade to 2.7.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.5GoPublished

    Helm Path Traversal

    CVE-2019-1000008 · GHSA-xrxm-mvqm-r553

    Affected
    • Go helm.sh/helm >= 2.0.0, < 2.12.2
    Fixed in
    2.12.2· Vendor fix available
    Issue
    All versions of Helm between Helm =2.0.0 and < 2.12.2 contains a CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in The commands helm fetch --untar and helm lint some.tgz that can result when chart archive files are unpacked a file may be unpacked outside of the target directory. This attack appears to be exploitable via a victim must run a helm command on a specially crafted chart archive. This vulnerability appears to have been fixed in 2.12.2.

    Recommended action: Upgrade to 2.12.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Low, CVSS 3.0GoPublished

    plugin.yaml file allows for duplicate entries in helm

    CVE-2020-15187 · GHSA-c52f-pq47-2r9j

    Affected
    • Go helm.sh/helm >= 2.0.0, < 2.16.11
    Fixed in
    2.16.11· Vendor fix available
    Issue
    Impact During a security audit of Helm's code base, Helm maintainers identified a bug in which a Helm plugin can contain duplicates of the same entry, with the last one always used. If a plugin is compromised, this lowers the level of access that an attacker needs to modify a plugin's install hooks, causing a local execution attack. To perform this attack, an attacker must have write access to the git repository or plugin archive (.tgz) while being downloaded (which can occur during a MITM attack on a non-SSL connection). Patches This issue has been patched in Helm 2.16.11 and Helm 3.3.2. Workarounds Make sure to install plugins using a secure connection protocol like SSL.

    Recommended action: Upgrade to 2.16.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Low, CVSS 3.4GoPublished

    Improper Sanitizing of plugin names in helm

    CVE-2020-15186 · GHSA-m54r-vrmv-hw33

    Affected
    • Go helm.sh/helm < 2.16.11
    Fixed in
    2.16.11· Vendor fix available
    Issue
    Impact Security researchers at Trail of Bits discovered that plugin names are not sanitized properly. As a result, a malicious plugin author could use characters in a plugin name that would result in unexpected behavior, such as duplicating the name of another plugin or spoofing the output to helm --help. Specific Go Packages Affected helm.sh/helm/v3/pkg/plugin Patches This issue has been patched in Helm 3.3.2. Workarounds Do not install untrusted Helm plugins. Examine the name field in the plugin.yaml file for a plugin, looking for characters outside of the [a-zA-Z0-9.-] range.

    Recommended action: Upgrade to 2.16.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Low, CVSS 2.2GoPublished

    Repository index file allows for duplicates of the same chart entry in helm

    CVE-2020-15185 · GHSA-jm56-5h66-w453

    Affected
    • Go helm.sh/helm < 2.16.11
    Fixed in
    2.16.11· Vendor fix available
    Issue
    Impact During a security audit of Helm's code base, security researchers at Trail of Bits identified a bug in which the a Helm repository can contain duplicates of the same chart, with the last one always used. If a repository is compromised, this lowers the level of access that an attacker needs to inject a bad chart into a repository. To perform this attack, an attacker must have write access to the index file (which can occur during a MITM attack on a non-SSL connection). Specific Go Packages Affected helm.sh/helm/v3/pkg/repo Patches This issue has been patched in Helm 3.3.2 and 2.16.11 Workarounds - do not install charts from repositories you do not trust - fetch charts using a secure channel of communication (such as TLS) - use helm pull to fetch the chart, then review the chart’s content (either manually, or with helm verify if it has been signed) to ensure it has not been tampered with - manually review the index file in the Helm repository cache before installing software.

    Recommended action: Upgrade to 2.16.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Low, CVSS 3.7GoPublished

    Aliases are never checked in helm

    CVE-2020-15184 · GHSA-9vp5-m38w-j776

    Affected
    • Go helm.sh/helm < 2.16.11
    Fixed in
    2.16.11· Vendor fix available
    Issue
    Impact During a security audit of Helm's code base, security researchers at Trail of Bits identified a bug in which the alias field on a Chart.yaml is not properly sanitized. This could lead to the injection of unwanted information into a chart. Patches This issue has been patched in Helm 3.3.2 and 2.16.11 Specific Go Packages Affected helm.sh/helm/v3/pkg/chartutil Workarounds Manually review the dependencies field of any untrusted chart, verifying that the alias field is either not used, or (if used) does not contain newlines or path characters.

    Recommended action: Upgrade to 2.16.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →