Helm Unsafe Link Following
CVE-2019-18658GHSA-p5pc-m4q7-7qm9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (helm.sh/helm 2.15.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go helm.sh/helm
- Affected
- >= 2.0.0, < 2.15.2
- Fixed in
- 2.15.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p5pc-m4q7-7qm9 lists affected ranges: Go helm.sh/helm >=2.0.0 <2.15.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-18658: 1.75% estimated exploitation activity in the next 30 days; percentile 77.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Helm 2.x before 2.15.2, commands that deal with loading a chart as a directory or packaging a chart provide an opportunity for a maliciously designed chart to include sensitive content such as /etc/passwd, or to execute a denial of service (DoS) via a special file such as /dev/urandom, via symlinks. No version of Tiller is known to be impacted. This is a client-only issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p5pc-m4q7-7qm9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-18658 Advisory: Helm Unsafe Link Following IDs: CVE-2019-18658, GHSA-p5pc-m4q7-7qm9 Record: https://patchnext.com/advisories/cve-2019-18658 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: helm.sh/helm 2.15.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go helm.sh/helm: affected >= 2.0.0, < 2.15.2; fixed in 2.15.2 ## Suggested inspection (read-only) - Go helm.sh/helm: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on helm.sh/helm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p5pc-m4q7-7qm9 (GitHub-reviewed advisory GHSA-p5pc-m4q7-7qm9 lists affected ranges: Go helm.sh/helm >=2.0.0 <2.15.2) Commands are suggestions: review each one before running it.
Loading voting…