High, CVSS 7.0GoPublished
simple-admin-core SQL Injection vulnerability
CVE-2025-51667 · GHSA-f2m2-4q6r-cwc4
- Affected
- Go github.com/suyuan32/simple-admin-core >= 1.2.0, < 1.6.8
- Fixed in
- 1.6.8· Vendor fix available
- Issue
- An issue was discovered in simple-admin-core v1.2.0 thru v1.6.7. The /sys-api/role/update interface in the simple-admin-core system has a limited SQL injection vulnerability, which may lead to partial data leakage or disruption of normal system operations.
Recommended action: Upgrade to 1.6.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.