simple-admin-core SQL Injection vulnerability
CVE-2025-51667GHSA-f2m2-4q6r-cwc4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/suyuan32/simple-admin-core 1.6.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/suyuan32/simple-admin-core
- Affected
- >= 1.2.0, < 1.6.8
- Fixed in
- 1.6.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f2m2-4q6r-cwc4 lists affected ranges: Go github.com/suyuan32/simple-admin-core >=1.2.0 <1.6.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:L
- EPSS
- CVE-2025-51667: 0.27% estimated exploitation activity in the next 30 days; percentile 19.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in simple-admin-core v1.2.0 thru v1.6.7. The /sys-api/role/update interface in the simple-admin-core system has a limited SQL injection vulnerability, which may lead to partial data leakage or disruption of normal system operations.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f2m2-4q6r-cwc4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-51667 Advisory: simple-admin-core SQL Injection vulnerability IDs: CVE-2025-51667, GHSA-f2m2-4q6r-cwc4 Record: https://patchnext.com/advisories/cve-2025-51667 (revision 1, source checked 26 Oct 2026, 15:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/suyuan32/simple-admin-core 1.6.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/suyuan32/simple-admin-core: affected >= 1.2.0, < 1.6.8; fixed in 1.6.8 ## Suggested inspection (read-only) - Go github.com/suyuan32/simple-admin-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/suyuan32/simple-admin-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f2m2-4q6r-cwc4 (GitHub-reviewed advisory GHSA-f2m2-4q6r-cwc4 lists affected ranges: Go github.com/suyuan32/simple-admin-core >=1.2.0 <1.6.8) Commands are suggestions: review each one before running it.
Loading voting…