Medium, CVSS 6.3GoAmendedPublished
Pion DTLS vulnerable to denial of service via panic while parsing a crafted ECDHE_PSK ServerKeyExchange message
CVE-2026-54908 · GHSA-wg4g-wm44-ch5j
- Affected
- Go github.com/pion/dtls/v3 <= 3.1.2
- Fixed in
- 3.1.4· Vendor fix available
- Issue
- Impact Remote denial of service via panic while parsing a crafted ECDHEPSK ServerKeyExchange message. Patches Upgrade to v3.1.4 or later. This version includes this patch https://github.com/pion/dtls/pull/839 which fixes the issue. Workarounds No work around; please upgrade to v3.1.4 or a newer version.
Recommended action: Upgrade to 3.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.