Skip to content

← Actionable
Medium, CVSS 6.3amended

Pion DTLS vulnerable to denial of service via panic while parsing a crafted ECDHE_PSK ServerKeyExchange message

CVE-2026-54908GHSA-wg4g-wm44-ch5j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pion/dtls/v3 3.1.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-54908: 0.54% estimated exploitation activity in the next 30 days; percentile 45.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Remote denial of service via panic while parsing a crafted ECDHEPSK ServerKeyExchange message. Patches Upgrade to v3.1.4 or later. This version includes this patch https://github.com/pion/dtls/pull/839 which fixes the issue. Workarounds No work around; please upgrade to v3.1.4 or a newer version.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 4 · amended ·

    Amended from ghsa record GHSA-wg4g-wm44-ch5j

  2. Revision 3 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 2 · amended ·

    Amended from osv record GO-2026-6165

  4. Revision 1 · created ·

    Published from osv record GHSA-wg4g-wm44-ch5j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-54908

Advisory: Pion DTLS vulnerable to denial of service via panic while parsing a crafted ECDHE_PSK ServerKeyExchange message
IDs: CVE-2026-54908, GHSA-wg4g-wm44-ch5j
Record: https://patchnext.com/advisories/cve-2026-54908 (revision 4, source checked 26 Oct 2026, 15:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/pion/dtls/v3 3.1.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/pion/dtls/v3: affected <= 3.1.2; fixed in 3.1.4

## Suggested inspection (read-only)
- Go github.com/pion/dtls/v3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/pion/dtls/v3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wg4g-wm44-ch5j (OSV record GHSA-wg4g-wm44-ch5j lists affected ranges: Go github.com/pion/dtls/v3 >=0 <3.1.4 (fixed))
- Verified: https://osv.dev/vulnerability/GO-2026-6165 (OSV record GO-2026-6165 lists affected ranges: Go github.com/pion/dtls/v3 >=0 <3.1.4 (fixed))
- Verified: https://github.com/advisories/GHSA-wg4g-wm44-ch5j (GitHub-reviewed advisory GHSA-wg4g-wm44-ch5j lists affected ranges: Go github.com/pion/dtls/v3 >=0 <=3.1.2)

Commands are suggestions: review each one before running it.

Loading voting…