Medium, CVSS 6.5GoPublished
MongoDB Tools Improper Certificate Validation vulnerability
CVE-2020-7924 · GHSA-6cwm-wm82-hgrw
- Affected
- Go github.com/mongodb/mongo-tools >= 100.0.0, < 100.2.0
- Fixed in
- 100.2.0· Vendor fix available
- Issue
- Usage of specific command line parameter in MongoDB Tools which was originally intended to just skip hostname checks, may result in MongoDB skipping all certificate validation. This may result in accepting invalid certificates.This issue affects: MongoDB Inc. MongoDB Database Tools 3.6 versions later than 3.6.5; 3.6 versions prior to 3.6.21; 4.0 versions prior to 4.0.21; 4.2 versions prior to 4.2.11; 100 versions prior to 100.2.0. MongoDB Inc. Mongomirror 0 versions later than 0.6.0.
Recommended action: Upgrade to 100.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.