Skip to content

← Actionable
Medium, CVSS 6.5

MongoDB Tools Improper Certificate Validation vulnerability

CVE-2020-7924GHSA-6cwm-wm82-hgrw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mongodb/mongo-tools 100.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2020-7924: 0.74% estimated exploitation activity in the next 30 days; percentile 54.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Usage of specific command line parameter in MongoDB Tools which was originally intended to just skip hostname checks, may result in MongoDB skipping all certificate validation. This may result in accepting invalid certificates.This issue affects: MongoDB Inc. MongoDB Database Tools 3.6 versions later than 3.6.5; 3.6 versions prior to 3.6.21; 4.0 versions prior to 4.0.21; 4.2 versions prior to 4.2.11; 100 versions prior to 100.2.0. MongoDB Inc. Mongomirror 0 versions later than 0.6.0.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6cwm-wm82-hgrw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-7924

Advisory: MongoDB Tools Improper Certificate Validation vulnerability
IDs: CVE-2020-7924, GHSA-6cwm-wm82-hgrw
Record: https://patchnext.com/advisories/cve-2020-7924 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mongodb/mongo-tools 100.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mongodb/mongo-tools: affected >= 100.0.0, < 100.2.0; fixed in 100.2.0

## Suggested inspection (read-only)
- Go github.com/mongodb/mongo-tools: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mongodb/mongo-tools.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6cwm-wm82-hgrw (GitHub-reviewed advisory GHSA-6cwm-wm82-hgrw lists affected ranges: Go github.com/mongodb/mongo-tools >=100.0.0 <100.2.0)

Commands are suggestions: review each one before running it.

Loading voting…