Skip to content

← Public intelligence

Go package

github.com/kedacore/keda/v2

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.9GoPublished

    KEDA has PostgreSQL connection string parameter injection via incomplete whitespace escaping

    CVE-2026-53572 · GHSA-6w3m-4hhp-775q

    Affected
    • Go github.com/kedacore/keda/v2 < 2.20.0
    Fixed in
    2.20.0· Vendor fix available
    Issue
    pkg/scalers/postgresqlscaler.go builds libpq-style connection strings by concatenating key=value pairs separated by spaces. Each tenant-controllable field (host, port, userName, dbName, sslmode) is passed through escapePostgreConnectionParameter: The function only escapes when a literal space is present. Per libpq/pgx documentation, parameters are also separated by tabs, newlines, carriage returns, and form feeds, and backslashes are parsed inside quoted strings. Because those characters are not detected, a tenant-supplied value like mydb\tsslmode=disable\thost=attacker.example.com splits into additional key=value tokens when parsed by pgx, injecting attacker-controlled connection parameters. Vulnerable code pkg/scalers/postgresqlscaler.go, lines 155–164 and 250–257. Impact Tenants with the ability to create a TriggerAuthentication or ScaledObject that populates any of host, port, userName, dbName, sslmode can: - Force sslmode=disable on a connection that the cluster owner…

    Recommended action: Upgrade to 2.20.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.2GoPublished

    KEDA has Arbitrary File Read via Insufficient Path Validation in HashiCorp Vault Service Account Credential

    CVE-2025-68476 · GHSA-c4p6-qg4m-9jmr

    Affected
    • Go github.com/kedacore/keda/v2 >= 2.18.0, < 2.18.3; < 2.17.3
    Fixed in
    2.18.32.17.3· Vendor fix available
    Issue
    Impact An Arbitrary File Read vulnerability has been identified in KEDA, potentially affecting any KEDA resource that uses TriggerAuthentication to configure HashiCorp Vault authentication. The vulnerability stems from an incorrect or insufficient path validation when loading the Service Account Token specified in spec.hashiCorpVault.credential.serviceAccount. An attacker with permissions to create or modify a TriggerAuthentication resource can exfiltrate the content of any file from the node's filesystem (where the KEDA pod resides) by directing the file's content to a server under their control, as part of the Vault authentication request. The potential impact includes the exfiltration of sensitive system information, such as secrets, keys, or the content of files like /etc/passwd. Patches The problem has been patched in v2.17.3 and 2.18.3 as well as in main branch. Workarounds The only effective workaround is the strict restriction of permissions for creating and modifying…

    Recommended action: Upgrade to 2.18.3 or 2.17.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →