KEDA has PostgreSQL connection string parameter injection via incomplete whitespace escaping
CVE-2026-53572GHSA-6w3m-4hhp-775q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kedacore/keda/v2 2.20.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/kedacore/keda/v2
- Affected
- < 2.20.0
- Fixed in
- 2.20.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6w3m-4hhp-775q lists affected ranges: Go github.com/kedacore/keda/v2 >=0 <2.20.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-53572: 0.39% estimated exploitation activity in the next 30 days; percentile 32.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary pkg/scalers/postgresqlscaler.go builds libpq-style connection strings by concatenating key=value pairs separated by spaces. Each tenant-controllable field (host, port, userName, dbName, sslmode) is passed through escapePostgreConnectionParameter: The function only escapes when a literal space is present. Per libpq/pgx documentation, parameters are also separated by tabs, newlines, carriage returns, and form feeds, and backslashes are parsed inside quoted strings. Because those characters are not detected, a tenant-supplied value like mydb\tsslmode=disable\thost=attacker.example.com splits into additional key=value tokens when parsed by pgx, injecting attacker-controlled connection parameters. Vulnerable code pkg/scalers/postgresqlscaler.go, lines 155–164 and 250–257. Impact Tenants with the ability to create a TriggerAuthentication or ScaledObject that populates any of host, port, userName, dbName, sslmode can: - Force sslmode=disable on a connection that the cluster owner…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6w3m-4hhp-775q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-53572 Advisory: KEDA has PostgreSQL connection string parameter injection via incomplete whitespace escaping IDs: CVE-2026-53572, GHSA-6w3m-4hhp-775q Record: https://patchnext.com/advisories/cve-2026-53572 (revision 1, source checked 26 Oct 2026, 15:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kedacore/keda/v2 2.20.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kedacore/keda/v2: affected < 2.20.0; fixed in 2.20.0 ## Suggested inspection (read-only) - Go github.com/kedacore/keda/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kedacore/keda/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6w3m-4hhp-775q (GitHub-reviewed advisory GHSA-6w3m-4hhp-775q lists affected ranges: Go github.com/kedacore/keda/v2 >=0 <2.20.0) Commands are suggestions: review each one before running it.
Loading voting…