Skip to content

← Public intelligence

Go package

github.com/jackc/pgx/v5

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8GoPublished

    Memory-safety vulnerability in github.com/jackc/pgx/v5.

    CVE-2026-33816 · GHSA-9jj7-4m8r-rfcm

    Affected
    • Go github.com/jackc/pgx/v5 < 5.9.0
    Fixed in
    5.9.0· Vendor fix available
    Issue
    Memory-safety vulnerability in github.com/jackc/pgx/v5.

    Recommended action: Upgrade to 5.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8GoPublished

    pgx contains memory-safety vulnerability

    CVE-2026-33815 · GHSA-xgrm-4fwx-7qm8

    Affected
    • Go github.com/jackc/pgx/v5 < 5.9.0
    Fixed in
    5.9.0· Vendor fix available
    Issue
    pgx is a pure Go driver and toolkit for PostgreSQL. pgx prior to v5.9.0 contains a memory-safety vulnerability.

    Recommended action: Upgrade to 5.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.3GoPublished

    Panic in Pipeline when PgConn is busy or closed in github.com/jackc/pgx

    GHSA-fqpg-rq76-99pq

    Affected
    • Go github.com/jackc/pgx/v5 < 5.5.2
    Fixed in
    5.5.2· Vendor fix available
    Issue
    Pipeline can panic when PgConn is busy or closed.

    Recommended action: Upgrade to 5.5.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 8.1GoPublished

    pgx SQL Injection via Protocol Message Size Overflow

    CVE-2024-27304 · GHSA-mrww-27vc-gghv

    Affected
    • Go github.com/jackc/pgx/v5 >= 5.0.0, < 5.5.4
    Fixed in
    5.5.4· Vendor fix available
    Issue
    Impact SQL injection can occur if an attacker can cause a single query or bind message to exceed 4 GB in size. An integer overflow in the calculated message size can cause the one large message to be sent as multiple messages under the attacker's control. Patches The problem is resolved in v4.18.2 and v5.5.4. Workarounds Reject user input large enough to cause a single query or bind message to exceed 4 GB in size.

    Recommended action: Upgrade to 5.5.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →