Panic in Pipeline when PgConn is busy or closed in github.com/jackc/pgx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/jackc/pgx/v5 5.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 5.5.2
- Fixed in
- 5.5.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fqpg-rq76-99pq lists affected ranges: Go github.com/jackc/pgx/v5 >=0 <5.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Pipeline can panic when PgConn is busy or closed.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fqpg-rq76-99pq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-fqpg-rq76-99pq Advisory: Panic in Pipeline when PgConn is busy or closed in github.com/jackc/pgx IDs: GHSA-fqpg-rq76-99pq Record: https://patchnext.com/advisories/ghsa-fqpg-rq76-99pq (revision 1, source checked 26 Oct 2026, 15:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/jackc/pgx/v5 5.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/jackc/pgx/v5: affected < 5.5.2; fixed in 5.5.2 ## Suggested inspection (read-only) - Go github.com/jackc/pgx/v5: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/jackc/pgx/v5. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fqpg-rq76-99pq (GitHub-reviewed advisory GHSA-fqpg-rq76-99pq lists affected ranges: Go github.com/jackc/pgx/v5 >=0 <5.5.2) Commands are suggestions: review each one before running it.
Loading voting…