High, CVSS 7.5GoPublished
github.com/ipfs/go-bitswap vulnerable to DOS unbounded persistent memory leak
GHSA-q3j6-22wf-3jh9
- Affected
- Go github.com/ipfs/go-bitswap < 0.12.0
- Fixed in
- 0.12.0· Vendor fix available
- Issue
- This package has been moved to github.com/ipfs/boxo/bitswap, this vulnerability is tracked there: https://github.com/ipfs/boxo/security/advisories/GHSA-m974-xj4j-7qv5 (CVE-2023-25568) Remediation This is a two step process: 1. Apply one of: - (recommended) upgrade from github.com/ipfs/go-bitswap to github.com/ipfs/boxo/bitswap. - If you are still using github.com/ipfs/go-bitswap and cannot upgrade to boxo, you can upgrade to github.com/ipfs/go-bitswap@v0.12.0, this will replace the go-bitswap implementation by stubs which points to boxo. 2. Open https://github.com/ipfs/boxo/security/advisories/GHSA-m974-xj4j-7qv5 and then follow boxo's remediation section. Vulnerable symbols - = v0.9.0; < v0.12.0 - github.com/ipfs/go-bitswap/server/internal/decision.(Engine).MessageReceived - github.com/ipfs/go-bitswap/server/internal/decision.(Engine).NotifyNewBlocks - github.com/ipfs/go-bitswap/server/internal/decision.(Engine).findOrCreate -…
Recommended action: Upgrade to 0.12.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.