Skip to content

← Public intelligence

Go package

github.com/google/fscrypt

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedGoPublished

    Denial of service via insufficient metadata validation

    GHSA-p93v-m2r2-4387

    Affected
    • Go github.com/google/fscrypt < 0.3.3
    Fixed in
    0.3.3· Vendor fix available
    Issue
    The PAM module for fscrypt through v0.3.2 doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to v0.3.3 or above. For more details, see CVE-2022-25327.

    Recommended action: Upgrade to 0.3.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedGoPublished

    Possible privilege escalation via bash completion script

    GHSA-w4f8-fxq2-j35v

    Affected
    • Go github.com/google/fscrypt < 0.3.3
    Fixed in
    0.3.3· Vendor fix available
    Issue
    The bash completion script for fscrypt through v0.3.2 allows injection of commands via crafted mountpoint paths, allowing privilege escalation under a specific set of circumstances. A local user who has control over mountpoint paths could potentially escalate their privileges if they create a malicious mountpoint path and if the system administrator happens to be using the fscrypt bash completion script to complete mountpoint paths. We recommend upgrading to v0.3.3 or above. For more details, see CVE-2022-25328.

    Recommended action: Upgrade to 0.3.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. UnratedGoPublished

    Possible filesystem space exhaustion by local users

    GHSA-chxf-fjcf-7fwp

    Affected
    • Go github.com/google/fscrypt < 0.3.3
    Fixed in
    0.3.3· Vendor fix available
    Issue
    fscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt v0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable. For more details, see CVE-2022-25326 and https://github.com/google/fscrypt#setting-up-fscrypt-on-a-filesystem.

    Recommended action: Upgrade to 0.3.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 5.0GoPublished

    Command injection in github.com/google/fscrypt

    CVE-2022-25328 · GHSA-wxjg-p59j-6c92

    Affected
    • Go github.com/google/fscrypt < 0.3.3
    Fixed in
    0.3.3· Vendor fix available
    Issue
    The bashcompletion script for fscrypt allows injection of commands via crafted mountpoint paths, allowing privilege escalation under a specific set of circumstances. A local user who has control over mountpoint paths could potentially escalate their privileges if they create a malicious mountpoint path and if the system administrator happens to be using the fscrypt bash completion script to complete mountpoint paths. We recommend upgrading to version 0.3.3 or above

    Recommended action: Upgrade to 0.3.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 5.5GoPublished

    User login denial of service in github.com/google/fscrypt

    CVE-2022-25327 · GHSA-8vwm-8vj8-rqjf

    Affected
    • Go github.com/google/fscrypt < 0.3.3
    Fixed in
    0.3.3· Vendor fix available
    Issue
    The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above

    Recommended action: Upgrade to 0.3.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 5.5GoPublished

    Uncontrolled Resource Consumption in github.com/google/fscrypt

    CVE-2022-25326 · GHSA-mpq4-rjj8-fjph

    Affected
    • Go github.com/google/fscrypt < 0.3.3
    Fixed in
    0.3.3· Vendor fix available
    Issue
    fscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt 0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable.

    Recommended action: Upgrade to 0.3.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. Medium, CVSS 6.5GoPublished

    Privilege Escalation in fscrypt

    CVE-2018-6558 · GHSA-qj26-7grj-whg3

    Affected
    • Go github.com/google/fscrypt < 0.2.4
    Fixed in
    0.2.4· Vendor fix available
    Issue
    The pamfscrypt module in fscrypt before 0.2.4 may incorrectly restore primary and supplementary group IDs to the values associated with the root user, which allows attackers to gain privileges via a successful login through certain applications that use Linux-PAM (aka pam).

    Recommended action: Upgrade to 0.2.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →