User login denial of service in github.com/google/fscrypt
CVE-2022-25327GHSA-8vwm-8vj8-rqjf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/google/fscrypt 0.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.3.3
- Fixed in
- 0.3.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8vwm-8vj8-rqjf lists affected ranges: Go github.com/google/fscrypt >=0 <0.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-25327: 0.11% estimated exploitation activity in the next 30 days; percentile 1.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8vwm-8vj8-rqjf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-25327 Advisory: User login denial of service in github.com/google/fscrypt IDs: CVE-2022-25327, GHSA-8vwm-8vj8-rqjf Record: https://patchnext.com/advisories/cve-2022-25327 (revision 1, source checked 26 Oct 2026, 14:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/google/fscrypt 0.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/google/fscrypt: affected < 0.3.3; fixed in 0.3.3 ## Suggested inspection (read-only) - Go github.com/google/fscrypt: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/google/fscrypt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8vwm-8vj8-rqjf (GitHub-reviewed advisory GHSA-8vwm-8vj8-rqjf lists affected ranges: Go github.com/google/fscrypt >=0 <0.3.3) Commands are suggestions: review each one before running it.
Loading voting…