Skip to content

← Public intelligence

Go package

github.com/buger/jsonparser

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5GoPublished

    github.com/buger/jsonparser has a denial of service vulnerability

    CVE-2026-32285 · GHSA-6g7g-w4f8-9c9x

    Affected
    • Go github.com/buger/jsonparser <= 1.1.1
    Fixed in
    1.1.2· Vendor fix available
    Issue
    The Delete function fails to properly validate offsets when processing malformed JSON input. This can lead to a negative slice index and a runtime panic, allowing a denial of service attack.

    Recommended action: Upgrade to 1.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5GoPublished

    Denial of Service in jsonparser

    CVE-2020-35381 · GHSA-8vrw-m3j9-j27c

    Affected
    • Go github.com/buger/jsonparser < 1.1.1
    Fixed in
    1.1.1· Vendor fix available
    Issue
    jsonparser before 1.1.1 allows attackers to cause a denial of service via a GET call.

    Recommended action: Upgrade to 1.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.5GoPublished

    Infinite Loop in jsonparser

    CVE-2020-10675 · GHSA-rmh2-65xw-9m6q

    Affected
    • Go github.com/buger/jsonparser < 1.0.0
    Fixed in
    1.0.0· Vendor fix available
    Issue
    The Library API in buger jsonparser through 2019-12-04 allows attackers to cause a denial of service (infinite loop) via a Delete call.

    Recommended action: Upgrade to 1.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →