github.com/buger/jsonparser has a denial of service vulnerability
CVE-2026-32285GHSA-6g7g-w4f8-9c9x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/buger/jsonparser 1.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/buger/jsonparser
- Affected
- <= 1.1.1
- Fixed in
- 1.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6g7g-w4f8-9c9x lists affected ranges: Go github.com/buger/jsonparser >=0 <=1.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2026-32285: 0.78% estimated exploitation activity in the next 30 days; percentile 55.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Delete function fails to properly validate offsets when processing malformed JSON input. This can lead to a negative slice index and a runtime panic, allowing a denial of service attack.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6g7g-w4f8-9c9x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-32285 Advisory: github.com/buger/jsonparser has a denial of service vulnerability IDs: CVE-2026-32285, GHSA-6g7g-w4f8-9c9x Record: https://patchnext.com/advisories/cve-2026-32285 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/buger/jsonparser 1.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/buger/jsonparser: affected <= 1.1.1; fixed in 1.1.2 ## Suggested inspection (read-only) - Go github.com/buger/jsonparser: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/buger/jsonparser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6g7g-w4f8-9c9x (GitHub-reviewed advisory GHSA-6g7g-w4f8-9c9x lists affected ranges: Go github.com/buger/jsonparser >=0 <=1.1.1) Commands are suggestions: review each one before running it.
Loading voting…