Skip to content

← Public intelligence

Go package

github.com/Anipaleja/nginx-defender

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.5GoPublished

    Default Credentials in nginx-defender Configuration Files

    CVE-2025-55740 · GHSA-pr72-8fxw-xx22

    Affected
    • Go github.com/Anipaleja/nginx-defender < 1.5.0
    Fixed in
    1.5.0· Vendor fix available
    Issue
    Impact This is a configuration vulnerability affecting nginx-defender deployments. Example configuration files config.yaml, docker-compose.yml contain default credentials (defaultpassword: "changemeplease", GFSECURITYADMINPASSWORD=admin123). If users deploy nginx-defender without changing these defaults, attackers with network access could gain administrative control, bypassing security protections. Who is impacted? All users who deploy nginx-defender with default credentials and expose the admin interface to untrusted networks. Patches The issue is addressed in v1.5.0 and later. Startup warnings are added if default credentials are detected. Documentation now strongly recommends changing all default passwords before deployment. Patched versions: 1.5.0 and later Will be fully patched in v1.7.0 and later Workarounds Users can remediate the vulnerability without upgrading by manually changing all default credentials in configuration files before deployment: Restrict access to the admin…

    Recommended action: Upgrade to 1.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →