Skip to content

← Actionable
Medium, CVSS 6.5

Default Credentials in nginx-defender Configuration Files

CVE-2025-55740GHSA-pr72-8fxw-xx22

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/Anipaleja/nginx-defender 1.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-55740: 0.24% estimated exploitation activity in the next 30 days; percentile 15.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This is a configuration vulnerability affecting nginx-defender deployments. Example configuration files config.yaml, docker-compose.yml contain default credentials (defaultpassword: "changemeplease", GFSECURITYADMINPASSWORD=admin123). If users deploy nginx-defender without changing these defaults, attackers with network access could gain administrative control, bypassing security protections. Who is impacted? All users who deploy nginx-defender with default credentials and expose the admin interface to untrusted networks. Patches The issue is addressed in v1.5.0 and later. Startup warnings are added if default credentials are detected. Documentation now strongly recommends changing all default passwords before deployment. Patched versions: 1.5.0 and later Will be fully patched in v1.7.0 and later Workarounds Users can remediate the vulnerability without upgrading by manually changing all default credentials in configuration files before deployment: Restrict access to the admin…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pr72-8fxw-xx22

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-55740

Advisory: Default Credentials in nginx-defender Configuration Files
IDs: CVE-2025-55740, GHSA-pr72-8fxw-xx22
Record: https://patchnext.com/advisories/cve-2025-55740 (revision 1, source checked 26 Oct 2026, 15:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/Anipaleja/nginx-defender 1.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/Anipaleja/nginx-defender: affected < 1.5.0; fixed in 1.5.0

## Suggested inspection (read-only)
- Go github.com/Anipaleja/nginx-defender: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/Anipaleja/nginx-defender.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pr72-8fxw-xx22 (GitHub-reviewed advisory GHSA-pr72-8fxw-xx22 lists affected ranges: Go github.com/Anipaleja/nginx-defender >=0 <1.5.0)

Commands are suggestions: review each one before running it.

Loading voting…