Skip to content

← Public intelligence

Go package

code.gitea.io/gitea

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

105 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.1GoPublished

    Gitea Missing Authorization vulnerability

    CVE-2022-0905 · GHSA-jr9c-h74f-2v28

    Affected
    • Go code.gitea.io/gitea <= 1.16.3
    Fixed in
    1.16.4· Vendor fix available
    Issue
    Gitea 1.16.3 and prior is vulnerable to missing authorization. A patch is available as part of the 1.16.4 release.

    Recommended action: Upgrade to 1.16.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8GoPublished

    Gitea Remote Code Execution (RCE)

    CVE-2018-18926 · GHSA-hf6f-jq25-8gq9

    Affected
    • Go code.gitea.io/gitea < 1.5.2
    Fixed in
    1.5.2· Vendor fix available
    Issue
    Gitea before 1.5.4 allows remote code execution because it does not properly validate session IDs. This is related to session ID handling in the go-macaron/session code for Macaron.

    Recommended action: Upgrade to 1.5.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.8GoPublished

    Reuse of one time passwords allowed in Gitea

    CVE-2021-45331 · GHSA-hfmf-q69j-6m5p

    Affected
    • Go code.gitea.io/gitea < 1.5.0
    Fixed in
    1.5.0· Vendor fix available
    Issue
    An Authentication Bypass vulnerability exists in Gitea before 1.5.0, which could let a malicious user gain privileges. If captured, the TOTP code for the 2FA can be submitted correctly more than once.

    Recommended action: Upgrade to 1.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Critical, CVSS 9.8GoPublished

    Improper Privilege Management in Gitea

    CVE-2021-45330 · GHSA-pg38-r834-g45j

    Affected
    • Go code.gitea.io/gitea < 1.6.0
    Fixed in
    1.6.0· Vendor fix available
    Issue
    An issue exsits in Gitea through 1.15.7, which could let a malicious user gain privileges due to client side cookies not being deleted and the session remains valid on the server side for reuse.

    Recommended action: Upgrade to 1.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 5.4GoPublished

    Cross-site Scripting in Gitea

    CVE-2021-28378 · GHSA-g95p-88p4-76cm

    Affected
    • Go code.gitea.io/gitea < 1.13.4
    Fixed in
    1.13.4· Vendor fix available
    Issue
    Gitea 1.12.x and 1.13.x before 1.13.4 allows XSS via certain issue data in some situations.

    Recommended action: Upgrade to 1.13.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →