Gitea Remote Code Execution (RCE)
CVE-2018-18926GHSA-hf6f-jq25-8gq9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (code.gitea.io/gitea 1.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.5.2
- Fixed in
- 1.5.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hf6f-jq25-8gq9 lists affected ranges: Go code.gitea.io/gitea >=0 <1.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2018-18926: 3.04% estimated exploitation activity in the next 30 days; percentile 87.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Gitea before 1.5.4 allows remote code execution because it does not properly validate session IDs. This is related to session ID handling in the go-macaron/session code for Macaron.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hf6f-jq25-8gq9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-18926 Advisory: Gitea Remote Code Execution (RCE) IDs: CVE-2018-18926, GHSA-hf6f-jq25-8gq9 Record: https://patchnext.com/advisories/cve-2018-18926 (revision 1, source checked 26 Oct 2026, 14:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: code.gitea.io/gitea 1.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go code.gitea.io/gitea: affected < 1.5.2; fixed in 1.5.2 ## Suggested inspection (read-only) - Go code.gitea.io/gitea: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on code.gitea.io/gitea. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hf6f-jq25-8gq9 (GitHub-reviewed advisory GHSA-hf6f-jq25-8gq9 lists affected ranges: Go code.gitea.io/gitea >=0 <1.5.2) Commands are suggestions: review each one before running it.
Loading voting…