High, CVSS 7.5crates.ioPublished
xml-rs vulnerable to denial of service via invalid token in XML document
CVE-2023-34411 · GHSA-7gf7-jv65-wjmh
- Affected
- crates.io xml-rs >= 0.8.9, < 0.8.14
- Fixed in
- 0.8.14· Vendor fix available
- Issue
- The xml-rs crate = 0.8.9 and < 0.8.14 for Rust and Crab allows a denial of service (panic) via an invalid <! token (such as <!DOCTYPEs/%<!A nesting) in an XML document.
Recommended action: Upgrade to 0.8.14 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.