Skip to content

← Actionable
High, CVSS 7.5

xml-rs vulnerable to denial of service via invalid token in XML document

CVE-2023-34411GHSA-7gf7-jv65-wjmh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (xml-rs 0.8.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io xml-rs

    Affected
    >= 0.8.9, < 0.8.14
    Fixed in
    0.8.14

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-34411: 1.16% estimated exploitation activity in the next 30 days; percentile 67.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The xml-rs crate = 0.8.9 and < 0.8.14 for Rust and Crab allows a denial of service (panic) via an invalid <! token (such as <!DOCTYPEs/%<!A nesting) in an XML document.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7gf7-jv65-wjmh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-34411

Advisory: xml-rs vulnerable to denial of service via invalid token in XML document
IDs: CVE-2023-34411, GHSA-7gf7-jv65-wjmh
Record: https://patchnext.com/advisories/cve-2023-34411 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: xml-rs 0.8.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io xml-rs: affected >= 0.8.9, < 0.8.14; fixed in 0.8.14

## Suggested inspection (read-only)
- crates.io xml-rs: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on xml-rs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7gf7-jv65-wjmh (GitHub-reviewed advisory GHSA-7gf7-jv65-wjmh lists affected ranges: crates.io xml-rs >=0.8.9 <0.8.14)

Commands are suggestions: review each one before running it.

Loading voting…