Skip to content

← Public intelligence

crates.io package

webpki-root-certs

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Unratedcrates.ioAmendedPublished

    Distrust compromised intermediate certificates in crypto/x509

    CVE-2026-111943

    Affected
    • crates.io webpki-root-certs >= 0.0.0-0, < 0.26.11; >= 0.26.12-0, < 1.0.10
    Fixed in
    1.0.100.26.11· Vendor fix available
    Issue
    On most platforms, Go uses the given system root certificates. However, in some narrower cases, the system trust stores may not be updated without further action. To defend against the narrower set of cases that may remain affected, a denylist was added in crypto/x509 to return an error when calling Verify with any of the known intermediate certificates that are no longer considered to be trustworthy.

    Recommended action: Upgrade to 1.0.10 or 0.26.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)osv.dev (2)osv.dev (3)osv.dev (4)osv.dev (5)Source checked Evidence →