Skip to content

← Actionable
Unratedamended

Distrust compromised intermediate certificates in crypto/x509

CVE-2026-111943

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rustls-webpki 0.104.0-alpha.8, 0.103.16; webpki-root-certs 1.0.10, 0.26.11; webpki-roots 1.0.10, 0.26.11; stdlib 1.27.3, 1.26.10; golang 1.27.3, 1.26.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io rustls-webpki

    Affected
    >= 0.0.0-0, < 0.103.16>= 0.104.0-alpha.1, < 0.104.0-alpha.8
    Fixed in
    0.104.0-alpha.8, 0.103.16
  • crates.io webpki-root-certs

    Affected
    >= 0.0.0-0, < 0.26.11>= 0.26.12-0, < 1.0.10
    Fixed in
    1.0.10, 0.26.11
  • crates.io webpki-roots

    Affected
    >= 0.0.0-0, < 0.26.11>= 0.26.12-0, < 1.0.10
    Fixed in
    1.0.10, 0.26.11
  • Go stdlib

    Affected
    < 1.26.10>= 1.27.0-0, < 1.27.3
    Fixed in
    1.26.10, 1.27.3
  • Bitnami golang

    Affected
    < 1.26.10>= 1.27.0-0, < 1.27.3
    Fixed in
    1.26.10, 1.27.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2026-111943: 0.40% estimated exploitation activity in the next 30 days; percentile 33.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

On most platforms, Go uses the given system root certificates. However, in some narrower cases, the system trust stores may not be updated without further action. To defend against the narrower set of cases that may remain affected, a denylist was added in crypto/x509 to return an error when calling Verify with any of the known intermediate certificates that are no longer considered to be trustworthy.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 10 · amended ·

    Amended from osv record BIT-golang-2026-111943

  2. Revision 9 · amended ·

    Amended from osv record RUSTSEC-2026-0383

  3. Revision 8 · amended ·

    Amended from osv record RUSTSEC-2026-0382

  4. Revision 7 · amended ·

    Amended from osv record RUSTSEC-2026-0381

  5. Revision 6 · amended ·

    Amended from osv record GO-2026-6809

  6. Revision 5 · amended ·

    Restored verified OSV alias package matches; original publication dates preserved

  7. Revision 4 · amended ·

    Amended from osv record RUSTSEC-2026-0383

  8. Revision 3 · amended ·

    Amended from osv record RUSTSEC-2026-0382

  9. Revision 2 · amended ·

    Amended from osv record RUSTSEC-2026-0381

  10. Revision 1 · created ·

    Published from osv record GO-2026-6809

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-111943

Advisory: Distrust compromised intermediate certificates in crypto/x509
IDs: CVE-2026-111943
Record: https://patchnext.com/advisories/cve-2026-111943 (revision 10, source checked 30 Oct 2026, 07:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rustls-webpki 0.104.0-alpha.8, 0.103.16; webpki-root-certs 1.0.10, 0.26.11; webpki-roots 1.0.10, 0.26.11; stdlib 1.27.3, 1.26.10; golang 1.27.3, 1.26.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io rustls-webpki: affected >= 0.0.0-0, < 0.103.16; >= 0.104.0-alpha.1, < 0.104.0-alpha.8; fixed in 0.104.0-alpha.8, 0.103.16
- crates.io webpki-root-certs: affected >= 0.0.0-0, < 0.26.11; >= 0.26.12-0, < 1.0.10; fixed in 1.0.10, 0.26.11
- crates.io webpki-roots: affected >= 0.0.0-0, < 0.26.11; >= 0.26.12-0, < 1.0.10; fixed in 1.0.10, 0.26.11
- Go stdlib: affected < 1.26.10; >= 1.27.0-0, < 1.27.3; fixed in 1.26.10, 1.27.3
- Bitnami golang: affected < 1.26.10; >= 1.27.0-0, < 1.27.3; fixed in 1.26.10, 1.27.3

## Suggested inspection (read-only)
- crates.io rustls-webpki: check the installed version with your package manager.
- crates.io webpki-root-certs: check the installed version with your package manager.
- crates.io webpki-roots: check the installed version with your package manager.
- Go stdlib: check the installed version with your package manager.
- Bitnami golang: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rustls-webpki, webpki-root-certs, webpki-roots, stdlib, golang.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GO-2026-6809 (OSV record GO-2026-6809 lists affected ranges: Go stdlib >=0 =1.27.0-0 <1.27.3 (fixed))
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0383 (OSV record RUSTSEC-2026-0383 lists affected ranges: crates.io webpki-root-certs >=0.0.0-0 =0.26.12-0 <1.0.10 (fixed))
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0382 (OSV record RUSTSEC-2026-0382 lists affected ranges: crates.io rustls-webpki >=0.0.0-0 =0.104.0-alpha.1 <0.104.0-alpha.8 (fixed))
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0381 (OSV record RUSTSEC-2026-0381 lists affected ranges: crates.io webpki-roots >=0.0.0-0 =0.26.12-0 <1.0.10 (fixed))
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0381 (Verified OSV alias repair: crates.io:webpki-roots [{"fixed": "0.26.11", "introduced": "0.0.0-0"}, {"fixed": "1.0.10", "introduced": "0.26.12-0"}])
- Verified: https://osv.dev/vulnerability/GO-2026-6809 (Verified OSV alias repair: Go:stdlib [{"fixed": "1.26.10", "introduced": "0"}, {"fixed": "1.27.3", "introduced": "1.27.0-0"}])
- Verified: https://osv.dev/vulnerability/RUSTSEC-2026-0382 (Verified OSV alias repair: crates.io:rustls-webpki [{"fixed": "0.103.16", "introduced": "0.0.0-0"}, {"fixed": "0.104.0-alpha.8", "introduced": "0.104.0-alpha.1"}])
- Verified: https://osv.dev/vulnerability/BIT-golang-2026-111943 (OSV record BIT-golang-2026-111943 lists affected ranges: Bitnami golang >=0 =1.27.0-0 <1.27.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…