Skip to content

← Public intelligence

crates.io package

vm-memory

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 2.5crates.ioPublished

    Default functions in VolatileMemory trait lack bounds checks, potentially leading to out-of-bounds memory accesses

    CVE-2023-41051 · GHSA-49hh-fprx-m68g

    Affected
    • crates.io vm-memory < 0.12.2
    Fixed in
    0.12.2· Vendor fix available
    Issue
    Impact An issue was discovered in the default implementations of the VolatileMemory::{getatomicref, alignedasref, alignedasmut, getref, getarrayref} trait functions, which allows out-of-bounds memory access if the VolatileMemory::getslice function returns a VolatileSlice whose length is less than the function’s count argument. No implementations of getslice provided in vmmemory are affected. Users of custom VolatileMemory implementations may be impacted if the custom implementation does not adhere to getslice's documentation. Patches The issue started in version 0.1.0 but was fixed in version 0.12.2 by inserting a check that verifies that the VolatileSlice returned by getslice is of the correct length. Workarounds Not Required References https://github.com/rust-vmm/vm-memory/commit/aff1dd4a5259f7deba56692840f7a2d9ca34c9c8 https://crates.io/crates/vm-memory/0.12.2

    Recommended action: Upgrade to 0.12.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.5crates.ioPublished

    Improper Synchronization and Race Condition in vm-memory

    CVE-2020-13759 · GHSA-mm4m-qg48-f7wc

    Affected
    • crates.io vm-memory < 0.1.1; >= 0.2.0, < 0.2.1
    Fixed in
    0.1.10.2.1· Vendor fix available
    Issue
    rust-vmm vm-memory before 0.1.1 and 0.2.x before 0.2.1 allows attackers to cause a denial of service (loss of IP networking) because readobj and writeobj do not properly access memory. This affects aarch64 (with musl or glibc) and x8664 (with musl).

    Recommended action: Upgrade to 0.2.1 or 0.1.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →