Skip to content

← Actionable
Low, CVSS 2.5

Default functions in VolatileMemory trait lack bounds checks, potentially leading to out-of-bounds memory accesses

CVE-2023-41051GHSA-49hh-fprx-m68g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vm-memory 0.12.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io vm-memory

    Affected
    < 0.12.2
    Fixed in
    0.12.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.5 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L
EPSS
  • CVE-2023-41051: 0.26% estimated exploitation activity in the next 30 days; percentile 17.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An issue was discovered in the default implementations of the VolatileMemory::{getatomicref, alignedasref, alignedasmut, getref, getarrayref} trait functions, which allows out-of-bounds memory access if the VolatileMemory::getslice function returns a VolatileSlice whose length is less than the function’s count argument. No implementations of getslice provided in vmmemory are affected. Users of custom VolatileMemory implementations may be impacted if the custom implementation does not adhere to getslice's documentation. Patches The issue started in version 0.1.0 but was fixed in version 0.12.2 by inserting a check that verifies that the VolatileSlice returned by getslice is of the correct length. Workarounds Not Required References https://github.com/rust-vmm/vm-memory/commit/aff1dd4a5259f7deba56692840f7a2d9ca34c9c8 https://crates.io/crates/vm-memory/0.12.2

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-49hh-fprx-m68g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-41051

Advisory: Default functions in VolatileMemory trait lack bounds checks, potentially leading to out-of-bounds memory accesses
IDs: CVE-2023-41051, GHSA-49hh-fprx-m68g
Record: https://patchnext.com/advisories/cve-2023-41051 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vm-memory 0.12.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io vm-memory: affected < 0.12.2; fixed in 0.12.2

## Suggested inspection (read-only)
- crates.io vm-memory: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vm-memory.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-49hh-fprx-m68g (GitHub-reviewed advisory GHSA-49hh-fprx-m68g lists affected ranges: crates.io vm-memory >=0 <0.12.2)

Commands are suggestions: review each one before running it.

Loading voting…