Skip to content

← Public intelligence

crates.io package

tokio-postgres

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.9crates.ioAmendedPublished

    tokio-postgres: Panic on a DataRow with fewer fields than columns allows denial of service

    GHSA-3gjw-f78c-vvpw

    Affected
    • crates.io tokio-postgres >= 0.4.0, < 0.7.18
    Fixed in
    0.7.18· Vendor fix available
    Issue
    A malicious or compromised server can send a row containing fewer fields than its row description declares columns. Reading one of the missing columns then panics with an out-of-bounds index, aborting the calling task. This affects even the otherwise non-panicking tryget, and both Row and SimpleQueryRow. Applications that connect only to a trusted database are not exposed; the risk applies to clients that may connect to untrusted or user-supplied servers, or whose connection can be intercepted by a man-in-the-middle.

    Recommended action: Upgrade to 0.7.18 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →