tokio-postgres: Panic on a DataRow with fewer fields than columns allows denial of service
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tokio-postgres 0.7.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io tokio-postgres
- Affected
- >= 0.4.0, < 0.7.18
- Fixed in
- 0.7.18
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3gjw-f78c-vvpw lists affected ranges: crates.io tokio-postgres >=0.4.0 <0.7.18 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3gjw-f78c-vvpw lists affected ranges: crates.io tokio-postgres >=0.4.0 <0.7.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
A malicious or compromised server can send a row containing fewer fields than its row description declares columns. Reading one of the missing columns then panics with an out-of-bounds index, aborting the calling task. This affects even the otherwise non-panicking tryget, and both Row and SimpleQueryRow. Applications that connect only to a trusted database are not exposed; the risk applies to clients that may connect to untrusted or user-supplied servers, or whose connection can be intercepted by a man-in-the-middle.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3gjw-f78c-vvpw
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-3gjw-f78c-vvpw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-3gjw-f78c-vvpw Advisory: tokio-postgres: Panic on a `DataRow` with fewer fields than columns allows denial of service IDs: GHSA-3gjw-f78c-vvpw Record: https://patchnext.com/advisories/ghsa-3gjw-f78c-vvpw (revision 3, source checked 26 Oct 2026, 15:43 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tokio-postgres 0.7.18. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io tokio-postgres: affected >= 0.4.0, < 0.7.18; fixed in 0.7.18 ## Suggested inspection (read-only) - crates.io tokio-postgres: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tokio-postgres. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3gjw-f78c-vvpw (OSV record GHSA-3gjw-f78c-vvpw lists affected ranges: crates.io tokio-postgres >=0.4.0 <0.7.18 (fixed)) - Verified: https://github.com/advisories/GHSA-3gjw-f78c-vvpw (GitHub-reviewed advisory GHSA-3gjw-f78c-vvpw lists affected ranges: crates.io tokio-postgres >=0.4.0 <0.7.18) Commands are suggestions: review each one before running it.
Loading voting…