Skip to content

← Public intelligence

crates.io package

theshit

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.4crates.ioPublished

    theshit's Improper Privilege Dropping Allows Local Privilege Escalation via Command Re-execution

    CVE-2026-21882 · GHSA-2j3p-gqw5-g59j

    Affected
    • crates.io theshit < 0.2.0
    Fixed in
    0.2.0· Vendor fix available
    Issue
    Impact Vulnerability Type: Local Privilege Escalation (LPE) / Improper Privilege Management / Arbitrary Command Execution. The application automatically re-executes the previously failed command but does not properly drop elevated privileges during this process. When the tool is executed with sudo or otherwise runs with an effective UID of root, it records the last executed command and attempts to rerun it. However, the application fails to restore the original unprivileged user context before re-executing the command. As a result, the retried command is executed with root privileges, even if the original command was issued by an unprivileged user. This allows a local attacker to intentionally trigger a failed command under elevated execution and gain arbitrary command execution as root via the retry mechanism. Who is impacted: Any system where this tool is executed with elevated privileges is affected. The risk is especially high in environments where the tool is permitted to run…

    Recommended action: Upgrade to 0.2.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.3crates.ioPublished

    theshit vulnerable to unsafe loading of user-owned Python rules when running as root

    CVE-2025-69257 · GHSA-95qg-89c2-w5hj

    Affected
    • crates.io theshit < 0.1.1
    Fixed in
    0.1.1· Vendor fix available
    Issue
    Impact Vulnerability Type: Local Privilege Escalation (LPE) / Arbitrary Code Execution. The application loads custom Python rules and configuration files from user-writable locations (e.g., ~/.config/theshit/) without validating ownership or permissions when executed with elevated privileges. If the tool is invoked with sudo or otherwise runs with an effective UID of root, it continues to trust configuration files originating from the unprivileged user's environment. This allows a local attacker to inject arbitrary Python code via a malicious rule or configuration file, which is then executed with root privileges. Who is impacted: Any system where this tool is executed with elevated privileges is affected. In environments where the tool is permitted to run via sudo without a password (NOPASSWD), a local unprivileged user can escalate privileges to root without additional interaction. Patches The issue has been fixed in version 0.1.1. The patch introduces strict ownership and…

    Recommended action: Upgrade to 0.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →