theshit vulnerable to unsafe loading of user-owned Python rules when running as root
CVE-2025-69257GHSA-95qg-89c2-w5hj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (theshit 0.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io theshit
- Affected
- < 0.1.1
- Fixed in
- 0.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-95qg-89c2-w5hj lists affected ranges: crates.io theshit >=0 <0.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-69257: 0.13% estimated exploitation activity in the next 30 days; percentile 2.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Vulnerability Type: Local Privilege Escalation (LPE) / Arbitrary Code Execution. The application loads custom Python rules and configuration files from user-writable locations (e.g., ~/.config/theshit/) without validating ownership or permissions when executed with elevated privileges. If the tool is invoked with sudo or otherwise runs with an effective UID of root, it continues to trust configuration files originating from the unprivileged user's environment. This allows a local attacker to inject arbitrary Python code via a malicious rule or configuration file, which is then executed with root privileges. Who is impacted: Any system where this tool is executed with elevated privileges is affected. In environments where the tool is permitted to run via sudo without a password (NOPASSWD), a local unprivileged user can escalate privileges to root without additional interaction. Patches The issue has been fixed in version 0.1.1. The patch introduces strict ownership and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-95qg-89c2-w5hj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-69257 Advisory: theshit vulnerable to unsafe loading of user-owned Python rules when running as root IDs: CVE-2025-69257, GHSA-95qg-89c2-w5hj Record: https://patchnext.com/advisories/cve-2025-69257 (revision 1, source checked 26 Oct 2026, 15:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: theshit 0.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io theshit: affected < 0.1.1; fixed in 0.1.1 ## Suggested inspection (read-only) - crates.io theshit: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on theshit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-95qg-89c2-w5hj (GitHub-reviewed advisory GHSA-95qg-89c2-w5hj lists affected ranges: crates.io theshit >=0 <0.1.1) Commands are suggestions: review each one before running it.
Loading voting…