High, CVSS 7.4crates.ioPublished
Starship vulnerable to shell injection via undocumented, unpredictable shell expansion in custom commands
CVE-2024-41815 · GHSA-vx24-x4mv-vwr5
- Affected
- crates.io starship >= 1.0.0, <= 1.19.0
- Fixed in
- 1.20.0· Vendor fix available
- Issue
- Starship is a cross-shell prompt. Starting in version 1.0.0 and prior to version 1.20.0, undocumented and unpredictable shell expansion and/or quoting rules make it easily to accidentally cause shell injection when using custom commands with starship in bash. Version 1.20.0 fixes the vulnerability. PoC Have some custom command which prints out information from a potentially untrusted/unverified source. Impact This issue only affects users with custom commands, so the scope is limited, and without knowledge of others' commands, it could be hard to successfully target someone.
Recommended action: Upgrade to 1.20.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.